We are investigating issues initialising uploads that contain many files
Incident Report for Digital Pigeon
Resolved
The issue effecting uploads with a large number of files has been resolved. Our apologies for the inconvenience.
Posted Sep 16, 2017 - 16:03 AEST
Investigating
We are investigating issues initialising uploads that contain many files. The initial work-around is to zip up your files into a single zip file before uploading...
Posted Sep 16, 2017 - 14:54 AEST